2009年11月12日 星期四

RU v4.78

This is a minor bug fixed version for v4.77

Fixed v4.77 caused Boxboro read the BDF=80/01/00=00/01/00.

The root cause is the PCIE MMIO base was wrong detected because of the same VID/DID on these 2 buses.

9 則留言:

匿名 提到...

Could you please tell me what website can be download ru478.exe?

Thanks!

整個的一個 提到...

I have uploaded v4.78 to download page.

Double Chiang 提到...

I use Ru4.78 on a ibex peak system (which has many pci device on it). Press F6 to display the pci list, and scroll to next page, the next page do not show pci device listing. Actually, I think the root cause if the PCI device has reach third page, so there is a problem to dispaly the pci devices.

整個的一個 提到...

I will try Ibexpeak. Thanks.

整個的一個 提到...

Double Chiang,

I checked the Ibexpeak board and RU lists all the PCI devices.

Do you mean the older version of RU can list them all?

Have you tried to manually input the Bus/Dev/Func number and found that device not in the F6 list?

Double Chiang 提到...

I used RU 4.78. Notice there is problem on default ibex peak platform, insert some PCI devices on the board, make sure the total PCI devices listing more than 3 pages, I have this symptom when scroll to next pages.

整個的一個 提到...

Before I tried 3 pages, can you clarify if you can manually read the PCI by entering BUS/DEV/FUNC?

Double Chiang 提到...

There is no problem to read single pci device.

I had attached a picture which indicate listing PCI device has problem on http://picasaweb.google.com/lh/photo/ou7jd-ZFinyNKQo6FaXCjA?authkey=Gv1sRgCKbswam_3fK37wE&feat=directlink .

Notice the yellow bar is the cursor bar.

整個的一個 提到...

Hi Double,

I think I missed your reply for a long time. I will try to simulate the problem you have.

It seems there is an alignment problem.